413 Request Entity to Large on Desktop Client Sync

Hello all. So I’ve scoured the forums to try and find a similar issue to me and cant seem to figure it out.

i’ve installed nextcloud in a jail through the official plugin in truenas.

I then setup a reverse proxy to access my data over the internet.

I am unable to sync larger files on my desktop nextcloud client, returning a 413 error each time. Oddly enough I am able t upload large files through the web client and app client on android. Very peculiar error considering a already modified client_max_body_size to 0; to disable checking.

Again only receiving this error in the windows desktop syncing client

Try editing all of these entities and changing the client_max_body_size in all of these files, then reboot the nextcloud server:

cd /usr/local/etc/nginx/ ee nginx.conf
and /usr/local/etc/php/ ee php.truenas.ini
and /usr/local/etc/nginx/conf.d/ ee nextcloud.inc

does this work?

1 Like

I was looking around and found lots of outdated information.
This post seems to be up to date for my situation at least (TrueNas core). Thanks so much. You saved me from a very large headache trying to track down the correct files…