2FA not working only for admin account

Nextcloud version: 14.0.3
Operating system and version: Ubuntu 18.04.1
Apache or nginx version: Apache/2.4.29
PHP version: 7.2.10

The issue you are facing: 2FA is not working for my Nextcloud admin account. 2FA for normal users works as expected. When enabling the feature it does not show any error but after logging out my admin account and logging back in, I am not asked for a TOTP code.
I already tried to solve the issue by removing the 2FA app, but without success.

Is this the first time you’ve seen this error?: I can not see any error message.

Steps to replicate it: I can not provide steps to replicate, because I think its a local problem (many out there are surely using 2FA for their admin account).

The output of your Nextcloud log in Admin > Logging: nothing provided there.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'x',
  'passwordsalt' => 'x',
  'secret' => 'x',
  'trusted_domains' => 
  array (
    0 => 'x',
  'datadirectory' => 'x',
  'overwrite.cli.url' => 'x',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud',
  'dbpassword' => 'x',
  'logtimezone' => 'UTC',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'theme' => '',
  'loglevel' => 2,
  'maintenance' => false,
  'trashbin_retention_obligation' => 'auto',
  'updatechecker' => false,
  'integrity.check.disabled' => false,
  'mail_smtpmode' => 'smtp',
  'mail_from_address' => 'x',
  'mail_domain' => 'x',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'x',
  'mail_smtpport' => '587',
  'mail_smtpname' => 'x',
  'mail_smtppassword' => 'x',
  'mail_smtpsecure' => 'tls',

The output of your Apache/nginx/system log in /var/log/____: nothing to post

Please report this at https://github.com/nextcloud/twofactor_totp. Thanks!