24.0.1 not properly set up to resolve "/.well-known/caldav"

I think I’ve read every post on this but still can’t fix it.

I’m on version 24.0.1, apache webserver (Apache/2.4.53 (Debian)), nextcloud is at /var/www/nextcloud, php8.1, ssl enabled with LetsEncrypt. Access via https is fine for web access. No reverse proxies involved.

“This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client.”

returns 404 page not found apache error page

I have added the rewrite rules from here (https://docs.nextcloud.com/server/24/admin_manual/issues/general_troubleshooting.html#service-discovery) to .htaccess (in /var/www), makes no difference.

I think I’m missing something very basic but don’t know what. Any ideas please?

OK, have solved my own problem.

It seems that all the guidance about leaving the connection URL in the iOS settings for the caldav connection as simply the domain name, is not correct.

When I entered:
(don’t forget the trailing /)
the connection worked fine.

I still don’t know what’s wrong with my apache config and the rewrite not working for .well-known

I can only think that Apple are trolling everyone who is trying to use caldav servers, constantly changing how they handle the protocol, creating confusion. You are not allowed to use caldav lol. Only Apple services!

1 Like