18.0.4, 17.0.6 and 16.0.10 are here! Plus Beta 5 for Nextcloud 19!

Update via web went smooth as always and I’m happy that I have the gallery-preview again. :slight_smile: The performance, again, improved a bit. Real happy so far.

I found one smaller issue in the photos app, maybe one of the others users can make a quick crosscheck:


Yes, I tested it quickly, the same error occurs to me :thinking:

1 Like

…now I am getting a Windows popup telling me 18.0.4 is available…still awaitng for the changelog.

With this said, I am very appreciative (and I am sure I am speaking for someone else, too) of Developers’ hard work on pushing this through.

Never had issues upgrading since starting with Nextcloud 13.

Upgrading from 17.0.5 today. However upon checking I was offered to upgrade to 17.0.6 first to my surprise which I did. This went well and web-updater completed. Then I checked again for an update and 18.0.4 appeared. When starting this the updater made a backup successfully and ticked all the other boxes. Then I’d proceed only to end up with a white screen.

Perhaps updates were happening too short after each other. Is there something running after upgrade which needs time to complete before attempting another upgrade?

Anyway, now working on restoring to 17.0.6 and making another backup of all the latest data to ensure all is secured before trying again to upgrade to 18.0.4.

Just expanding for educational purposes and future reference on getting through this update
After successful restore, I tried again with web-updater with same result. Download done, all boxes ticked and then blank screen. End of upgrade.

Went through the terminal and entered:

sudo -u www-data php occ maintenance:mode --on
sudo -u www-data php occ upgrade

That (re)started the upgrade process. Appeared to go well with a whole lot of updates and checking until:

Checking for update of app spreed in appstore
Update app spreed from appstore
Repair error: Repair step ‘OCA\Talk\Migration\FixNamespaceInDatabaseTables’ is unknown
PHP Fatal error: Cannot declare class OCA\Talk\Migration\Version8000Date20200331144101, because the name is already in use in /var/www/nextcloud/apps/spreed/lib/Migration/Version8000Date20200331144101.php on line 54

I deleted this specific file risking loss of data. I’m just having a ‘family’ instance so I proceeded.

After deletion I ran again:

sudo -u www-data php occ upgrade
It continued with updating the other apps and finished in ‘Update Successful’.

After that just:

sudo -u www-data php occ maintenance:mode --off

And back to the browser to check my instance. All good and upgrade successful and no loss of any data.

Do have an integrity issue now with spreed app. That was kind of expected. Will have to extract the original files somehow and restore the folder I deleted them from. Found them here: https://github.com/nextcloud/spreed/tree/master/lib/Migration

1 Like

I’m getting this docker error;
Pulling nextcloud (nextcloud:18.0.4)... 18.0.4: Pulling from library/nextcloud ERROR: no matching manifest for linux/amd64 in the manifest list entries

Looks like the linux/amd64 OS is missing on the docker hub. Running Intel Nuc with:
NAME="Ubuntu" VERSION="19.04 (Disco Dingo)" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 19.04"

Hi @marinela,

I just noticed the blog post states disabling flows for users works with

occ config:app:set workflowengine userscopedisabled --value yes

but after that didn’t work for me I checked the code and found that it should be

occ config:app:set workflowengine user_scope_disabled --value yes

…which works like a charm. Probably the underscores just went missing?


I’m using the nextcloud:fpm-alpine image.

Calling docker-compose pull && docker-compose up -d is not updating NextCloud 18.0.3 to 18.0.4.

Might be due to: https://github.com/nextcloud/docker/issues/1089

If maintainers do

  • a quick

  • out-of-cycle update

  • without changelog and

    • that it is distributed to everybody (instead of this slow-rolling-release cycle they are usually doing)

It is a good indicator for that this release is fixing (“only”) some critical security issue. Otherwise, they’d breathe in and out before, plan it, release it in steps and proudly make announcements, I guess.

Now it seems that this update breaks some installations, which is of course bad, but its probably better than instances and servers taken over or destroyed by people who figured out an exploit to something.

Thanks, maintainers and contributors!

1 Like

Mmhmm. Unfortunately collabora is vital for me so will be moving back to 18.0.3.

I have NC18 in nginx and collabora in docker since long. It works also after update. And by the way update was very smoth. Why did you have to remove all files in var/www? Maybe the fault is yours and not NC18 update.

How is your set-up and how is collabora installed?

I use the collabora docker. I’ve already reinstalled the docker instance with no success.

Here is the error - https://pastebin.com/gtcHqWgp

I am no programmer so cannot interpret this. I would go back to 18.0.3, update all apps and try an update again. If it goes wrong I would try upgrade from the terminal.

Yes, I’m not going to continue to derail the topic. I had to manually reinstall the files as the web upgrade failed midway through. Thankfully I have a full backup.

All the same, the rest of nextcloud is fully function. It’s specifically collabora with the issue. A full app reinstallation did not fix it, nor did reinstalling the container.

Since I use postgresql, curious on if that’s the issue. I will indeed try a fresh installation of 18.0.4 to see if it was an upgrade issue.

Did a manual upgrade from my backup instead of the web upgrade. Fixed the problem - have removed my previous posts to avoid misinformation.

I need to stop jumping the gun on these things.

Hi @simonspa

Thanks for pointing that out. It happens every now and then that some markdown control characters get lost when the blog is transferred over here to the forum. So maybe that was it again.
I changed the text according to your findings.

Thanks a lot.

Nevermind, after fully reinstalling and importing all of my contacts etc the issue came right on back. Sticking with 18.0.3 for now.

Thank you for the help though!

Hi @Schmu

thanks for fixing it here - but the issue is also present in the actual blog post on the NC website, which is why I addressed @marinela - at least she’s listed as the author…


1 Like

Here is a statement from the twitter Account:

sadly github is having issues so we didn’t manage to grab the changelog yet… probably at some point today.

1 Like

Sorry for the very newbie question, in version 18.0.3, this is normal?

occ upgrade
Nextcloud is already latest version


Try switching to unstable and then again to stable branch.