0B Quota messes up chunked uploading from desktop client and WebUI

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 14.0.3
Operating system and version (eg, Ubuntu 17.04): Ubuntu 16.04
Apache or nginx version (eg, Apache 2.4.25): Server version: Apache/2.4.18 (Ubuntu)
PHP version (eg, 7.1): PHP 7.1.23-3+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Oct 25 2018 06:43:19) ( NTS )

The issue you are facing:
We use 0B Quota in advanced ldap-settings to prevent Users creating files or folderes outside external storages. This worked fine in NC 13.
After updating to NC 14 we can’t upload files bigger than 10 MB through Desktop Client and WebUI.

Is this the first time you’ve seen this error? (Y/N):Y

Steps to replicate it:

  1. Set 0B Quota in LDAP/AD-Intergration - Advanced Settings
  2. Put an file bigger than 10MB in your locally synced folder
  3. You get an error message

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/log/____:


Your issue looks the same here.

Thank you very much - solved teh problem!